Issues

  • Error in OpenAPI spec

    When trying to generate code via swagger I get an error. There seems to be an error in the '/product/getProductBalances' section due to an empty set of responses.

    Status: Open | Reported by Zak Sat, 12 Aug 2017 19:30:14 GMT
  • 401 Unauthorized

    When trying to run a query it generates this issue: "statusCode": 401, "message": "Access denied due to missing ecomdash subscription key. Make sure to include a valid ecomdash subscription key (ecd-subscription-key) in the header." I have double checked the subscription key and insured correct entry.

    Status: Proposed | Reported by James Fri, 14 Jul 2017 22:22:46 GMT
  • Is there an API to Update existing products?

    I see there is an API to create a product, but it would be great if there was a similar API to update existing products.

    Status: Open | Reported by Carmon Tue, 11 Jul 2017 13:01:48 GMT
  • Having difficulties Setting Quantity

    I am getting this response...{ "status": "Failure", "messages": [ "Index 0: Could not update product with SKU 'Z1' to 99. Error Message: Could not update product with Sku 'Z1' because WarehouseId was not provided." ] } The need for Warehouse ID is not in the dicumentation. If the documentation is not updated, can you provide a link to udated information this has cost me a lot of time.

    Status: Proposed | Reported by Shawn Sat, 18 Feb 2017 23:54:20 GMT
  • Retrieving order is reporting a false success message

    I am sending the request {"Pagination": {"PageNumber" : 1,"ResultsPerPage" : 200},"DateType" : "CreatedDate","FromDate" : "2016-12-01","ToDate" : "2016-12-06","StorefrontId" : null,"OnlyNeedsFulfillment" : false,"IncludeLineItems" : true,"IncludeCustomerInfo": true,"IncludeShippingInfo": true} but receiving the response {"status":"Success","messages":["Unexpected EntityCommandExecutionException exception has occurred."]} I'm not sure what is wrong, as I have had success using this exact request before. I'm not sure what this exception means, and even if there is an error, the response should not be sending me "Success" as the status. Please advise.

    Status: Proposed | Reported by Justin Thu, 19 Jan 2017 20:16:19 GMT
  • Date range too narrow - no throttling limits documented

    I'm attempting to make a getOrders call for a wide date range, but the API only support 5-day periods. To cover the entire range, I need to make a large number of 5-day requests. However, I eventually receive a 429 response for Too Many Requests, with the message: "Rate limit is exceeded. Try again in 49 seconds." The API documentation does not mention the throttling limits, so I don't know how many requests I can make in a given period of time. Could you please define this limit?

    Status: Proposed | Reported by Justin Wed, 11 Jan 2017 14:46:40 GMT
  • shipments/create - POSTing a valid OrderId returns "Required property 'OrderId' not found in request body."

    I am attempting to create a shipment. I retrie a specific order, validate the line items, and build a request, but when I submit a valid request, I get an error response 400 saying that I need to include the order ID, which I am. I have attached my request and the response.

    Status: Resolved | Reported by Justin Fri, 11 Nov 2016 15:01:38 GMT
  • Inventory/UpdateQuantityOnHand reports "Success" but has no effect

    I'm submitting quantity oh hand updates through the API for two inventory entries, and I get a "Success" response with no additional messages, but the quantities are not updated on the site.

    Status: Resolved | Reported by Justin Tue, 08 Nov 2016 14:19:40 GMT
  • storefronts API returns incorrectly formatted ID

    Doing a GET request for /storefronts returns a list of storefronts but the IDs are not integers as described by the API sample response. For example, I am receiving a storefront ID of "61466.0" for the storefront I have created in our account.

    Status: Resolved | Reported by Justin Fri, 04 Nov 2016 14:55:02 GMT

You're not signed in. Please sign in to report an issue or post a comment.